4

Retro: Atari EtherNEC

Atari EtherNEC

Atari EtherNEC

Hier nun die angekündigte Beschreibung zum EtherNEC an meinem Atari 1040STE.
Dazu eine kurze Übersetzung einer englischen Seite:
„Zusammen mit Dr. Thomas Redelberger haben wir eine Lösung kreiert um vom alten ST bis zum TT und Falcon Ethernet zu haben. Thomas stellte sicher, dass es einen guten Treiber-Support gab der drei Stacks unterstützte: Sting, MagxNet und MintNet. Das Projekt ist Open Source einschließlich der Hardware.
Es wird zwei Karten geben. Eine wird an den ROM-Port (auch Cartridge-Port genannt) angesteckt. Das ist eine doppelseitige Karte welche ca. 25mm breit und 50mm lang ist. Die zweite Karte ist die Karte mit den Komponenten und dem ISA Steckplatz.
Diese ist ungefähr 30mm breit und 80mm lang. Die beiden Karten sind durch ein 40poliges Flachbandkabel verbunden das 15cm lang ist. Das Kabel ist so kurz weil der ROM-Port nicht gebuffert ist und auf dem schnelleren Falcon Probleme macht, wenn es länger ist. Wenn ein längeres Kabel benötigt wird, kann man sich selbst eines in der entsprechenden Länge machen.

Es gibt verschiedene Optionen. Mancher wird kein Gehäuse benötigen, mancher wird keine ISA Netzwerkkarte benötigen. Zur Zeit werden Netzwerkkarten verwendet die auf dem Realtek 8019 basieren.“
Zur Zeit gibt es die EtherNEC über folgende Seite zu beziehen: Atari EtherNEC Order Form

Der Anschluss der EtherNEC ist kinderleicht. Einfach den ROM-Port-Adapter auf der linken Seite anstecken (die entsprechend beschriftete Seite nach oben) und ein Netzwerkkabel anschließen.

Dann geht’s ans konfigurieren

benötigte Software (von einem Atari 1040STE ausgehend):
Sting:

STING126 (432.6 KiB)


wdialog:

Wdialog204 Ger (41.8 KiB)


XControl:

Xctl131 (72.4 KiB)


qed:

Qed (202.8 KiB)


ftp Server:

Ftp Serv (42.2 KiB)


AFTP:

Aftp155b (139.8 KiB)

Anleitung:
Auf diesen Seiten möchte ich darstellen, wie man einen Atari mit einer EtherNec Netzwerkkarte ins World Wide Web bringt, und was man überhaupt davon hat. Ich gehe davon aus, daß der geneigte Leser Grundkenntnisse des Betriebssystems TOS bzw. seiner Derivate hat.

Zunächst einmal braucht man einen 68k-Atari, also ST, TT oder Falcon. Zwei MB Speicher sollten schon drin sein, ansonsten kann man nach der Einrichtung kaum etwas mit dem Rechner anfangen. Dann benötigt man ein EtherNEC, das aus einer NE2000 kompatiblen ISA Netzwerkkarte mit Realtek 8019 Chipsatz sowie einem Adapter für den Rom-Port des Atari Computers besteht. Der einzige Atari, den man damit nicht ins Netz bekommt, ist das ST-Book.

An Software benötigt man den TCP/IP-Stack Sting, den Netzwerkkartentreiber (enec.stx, enec3.stx) aus dem Ethernet-Paket sowie den Editor qed oder einen beliebigen anderen Editor, der echte Tabs setzen kann. Dann sollte man noch Entpacker für Zip- und LZH-Archive auf dem Rechner haben. Wenn man TOS ohne Multitasking benutzen möchte, muß noch die Systemerweiterung wdialog.prg installiert werden. Zuletzt sollte auch noch Xcontrol installiert sein.

Das EtherNEC wird an den Rom-Port des Ataris gesteckt. Nun kann man den Rechner starten.
Auf dem Bootlaufwerk erstellt man die Ordner ‚auto‘ und ‚gemsys‘. Ich schlage vor, daß noch ein weiterer Ordner ‚daten‘ für die gepackten Dateien verwendet wird. Außerdem empfiehlt es sich, die Anwenderprogramme in einen eigenen Ordner, z.B. ‚apps‘ zu legen.
Das Sting-Paket wird ausgepackt und die Dateien aus dem entpackten Auto-Ordner nach c:\auto\ verschoben. Die Ordner ’sting‘ und ‚cpx‘ legt man nach c:\gemsys\.
Aus dem Ethernet-Paket zieht man sich nur die Datei enec.stx (für 68000 Ataris) oder enec3.stx (für 68030 Ataris) und legt sie in c:\gemsys\sting\. Damit sind die notwendigen Dateien für die Nutzung von TCP/IP an Ort und Stelle.

Als nächstes startet man nun den Editor qed (oder welchen man diesem vorzieht), mit dem einige Dateien verändert werden:
Erstens wird in der Datei c:\auto\sting.inf der Pfad c:\gemsys\sting\ eingetragen.
Zweitens wird in der Datei c:\gemsys\sting\route.tab die Zeile 0.0.0.0[TAB]0.0.0.0[TAB]EtherNet[TAB][Ip-Addresse des Routers] eingetragen. Die Tabs müssen echte Tabs sein, sonst wundert man sich hinterher, wenn es nicht läuft. Andere Zeilen werden durch Setzen eines ‚#‘ auskommentiert.
Drittens wird in der Datei c:\gemsys\sting\default.cfg der Eintrag NAMESERVER = [Ip-Addresse des Nameservers] verändert.
Nun öffnet man im Kontrollfeld das Modul Sting Port Setup und wählt die Verbindung ‚Ethernet‘ aus. Dort wird als IP-Adresse eine Adresse innerhalb der IP-Range, die der Router verwaltet, eingetragen. Als Subnet Mask setzt man den Wert ‚255.255.255.0‘. Das Kästchen ‚active‘ sollte einen Haken bekommen. In ‚General‘ wird noch die Hardware ‚NE2000‘ ausgesucht.

Zur Datenübertragung habe ich mir auf meinem NAS einen FTP-Server eingerichtet, auf den ich mit AFTP zugreife. Mit FTP_SRV ist auch möglich den Atari als FTP-Server zu verwenden und Daten direkt mit Filezilla hochzuladen.

Man kann auch über den DOS-Prompt Daten hochladen. Hier erreiche ich im Moment auf meinem 1040 STE ca. 11,5 KB/sec 🙂
Als ich Filezilla als FTP-Programm in Zusammenarbeit mit FTP_SRV auf dem Atari verwendet habe, hatte ich große Probleme Dateien zu übertragen. Dann bin ich im Atari-Forum auf einen Hinweis gestoßen und testet den TotalCommander. Auch dieser hatte anscheinend Probleme – bei der Überprüfung der Dateigröße hat er immer nachgefragt. Wenn man aber in der TC-Datei „wcx_ftp.ini“ in der Sektion für den „Atari-Server“ die Zeile „SpecialFlags=32“ einfügt – funktioniert der Upload ohne Probleme!

Atari EtherNEC - Seitenansicht

Atari EtherNEC – Seitenansicht

Atari EtherNEC - Rückansicht

Atari EtherNEC - Seitenansicht

Atari EtherNEC – Seitenansicht

Atari EtherNEC - Bootscreen mit StinG am Schluss

Atari EtherNEC – Bootscreen mit StinG am Schluss

Atari EtherNEC - angeschlossen an 1040 STE

Atari EtherNEC – angeschlossen an 1040 STE

Atari EtherNEC - angeschlossen an 1040 STE

Atari EtherNEC – angeschlossen an 1040 STE

4 Kommentare

  1. Hallo !
    Ich versuchte, die Dateien
    „Sting,wdialog,XControl,qed,ftp Server,AFTP“ zu laden.
    Leider sind die Dateien Müll, unter Downloads auch nicht zu finden.

    HILFE !

  2. Danke für den Hinweis das die Links kaputt waren – der Download sollte nun klappen.
    Ich habe die Dateien auch im Attari-Downloadbereich eingefügt (der Bereich ist noch neu und
    noch nicht so gut „gefüllt“)

  3. Danke für den Artikel. Ich habe nun auch zwei Ataris (Mega 1, der wg. seiner 1MB RAM wohl ausscheidet und einen TT030 mit 4+16MB RAM) und eine EtherNEC Box, aber ich sehe irgendwie keinen Download Link?

  4. Hallo Stefan,
    der Artikel ist schon ein paar Tage alt 🙂 Ich hatte die Download-Links nicht korrigiert nachdem ich die Software mal umstellen musste. Die Links sind nun auf die Schnelle korrigiert – ich hoffe sie funktionieren nun wieder!

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.