Zum Inhalt springen

Epson SMD-400 Wiederbelebung [Atari ST]

EPSON-SMD-400

EPSON-SMD-400

Viele haben ja einen Atari ST funktionsfähig am Laufen, doch habt ihr euch schon mal Gedanken gemacht, wie es eurem Diskettenlaufwerk geht? Es gibt ein Modell im Atari ST, in dem billige Elkos verbaut sind, die nach so vielen Jahren auslaufen können und die Steuerplatine der Motorelektronik zerstören können!

Dafür gibt es Abhilfe:

Es handelt sich um das Epson SMD-400 Laufwerk. In diesem Laufwerk habe ich wohl was entdeckt, was Amiga-Fans 600/1200 und ihre SMD-Elkos Platzer ganz besonders kennen, ich befürchte, die drei kleinen SMD Elkos haben schon begonnen, die Kontakte zu korrodieren, … In diesem Fall sollte man schnell handeln und die Elkos wegdrehen und normale Elkos einlöten. Es handelt sich um 10 µF Elkos (insgesamt 5 Stück), und diese sollten so schnell wie möglich entfernt werden!

Drei Elkos sind an der Vorderseite sichtbar, der vierte Elko ist ganz hinten links, der fünfte hinten rechts verlötet. Dazu muss die gesamte Auswurf-Mechanik zerlegt werden.

Wichtig ist, alle fünf Elkos durch beherztes Drehen in beide Richtungen an der Platine abzubrechen und alle Stellen um den Elko mit Kontakt WL Reiniger zu behandeln, um das ausgelaufene Elektrolyt zu neutralisieren. Dies ist ein ganz wichtiger Schritt. Dann werden alle Pads mittels Lötkolben von den alten Kontakten befreit und mittels Entlötlitze werden alle Kontakte gereinigt.

Epson_SMD_400_2Epson_SMD_400_3
Hier das halbzerlegte EPSON-SMD-400 Floppydrive - hier erkennt man schon die auslaufenden ElkosHier sieht man schon anhand eines entfernten Elkos, dass dieser schon ausgelaufen ist und beginnt, die Platine zu zerstören

Epson_SMD_400_4

Hier sieht man noch einen ganz gemeinen Elko. Dieser befindet sich von vorne gesehen links hinten. Dazu muss man den oberen Laufwerksschlitten entfernen:

Dann muss jeder Kontakt mit frischem Lötzinn benetzt werden. Als Ersatz-Elkos können Standard 10 µF Elkos verwendet werden, die hier liegend (Siehe Bild) eingebaut werden können. Wichtig ist, die Negativ-Seite des Elkos mit – (Minus) zu verbinden. + (Plus) ist auf der Motorsteuerungsplatine gekennzeichnet. Auf diese Verbindungsweise werden die neuen Elkos verlötet. Die Minus-Seite (Strich) am Elko ist Minus, die unbeschriftete Seite ist Plus. Achtet darauf, die Elkos nicht in der Polarität zu vertauschen, sonst habt ihr einen kleinen China-Böller im Laufwerk 🙂

Epson_SMD_400_5

Hier sieht man die nächste, auf Bayrisch gesagte Sauerei – Weg mit dem Elko! Und natürlich weg mit der ganzen Auswurfmechanik

Epson_SMD_400_6

Epson_SMD_400_7

Hier sieht man die gesamte Motorsteuerungsplatine mit den entfernten Elkos. Was für eine, auf Bayrisch gesagte "Sauerei"! Hier müssen alle Lötpads und auch rundherum die Kontakte mit Kontakt WL gereinigt werden, damit das Elektrolyt neutralisiert wird, dann müssen alle Kontakte entlötet und neu verzinnt werden.Hier ser ihr den schönen "Laufwerks-Hack" mit total übertriebenen und neuen 105° low ESR Elkos, in liegender Bauweise. So braucht man keine SMD Elkos und kann normale Elkos verwenden. Durch die Dicke der Elkos gibt es auch kein Problem - der untere Laufwerksschlitten hat keine Reibestellen an den Elkos. Zu beachten ist, dass die Polarität wie auf der Platine gekennzeichnet ist passt, ansonsten kann ein falsch gepolter Elko platzen, und das wollen wir nicht 🙂

Die Elkodicke passt wunderbar unter dem Schlitten, sodass sich hier nichts abwetzt.

Bei dieser „Retro“ Reparatur setze ich Kenntnisse von Zerlegen von Laufwerken voraus. Besonders die Federn für die Auswurfmechanik können für einen ungeübten zum Haare ausreißen führen 🙂 Die zwei Federn für den Schlitten unten sind kein Problem aber die Feder für den oberen Schlitten, was sich links hinten befindet, treibt einen schon in den Wahnsinn, wenn man einen gewissen Trick nicht kennt.

Epson_SMD_400_8

Hier der neue „Strom-Hack“ mit verbauter Disk-Auswurfmechanik. Verflucht schon mal die Feder hinten links, die zwei normalen Federn für die untere Auswurfmechanik sind Peanuts gegenüber DIESER Feder. Und wenn ihr schon flucht, dann flucht nochmal, denn die Feder ist nicht lustig.

Somit ist das Laufwerk wieder revidiert und sollte wieder einen einwandfreien Dienst tun. Probleme könnte noch der Kontaktschalter für die Diskettenerkennung und für den Schreibschutz bereiten, doch dieses wird demnächst in einem neuen Thema behandelt.

Epson_SMD_400_9

Hier nochmal die Draufsicht vom Laufwerk mit eingeclipster Front. Kein Problem, hier zwickt nichts und es passt.

6 Gedanken zu „Epson SMD-400 Wiederbelebung [Atari ST]“

  1. Hallo Gerhard,

    beim Durchsuchen in diversen ATARI-Foren zum Thema:
    Reparatur von „alten“ Floppy-Laufwerken, bin ich
    auf Deine Seite „Jungsis Corner“ aufmerksam geworden.
    Da gibt es auch den erfolgreichen Bericht:
    „Epson SMD-400 Wiederbelebung [Atari ST]“
    vom 01.12.2015 von „Darius“
    Nach ca. 25 Jahren habe ich meinen ATARI STE vom Dach-
    boden hervor geholt und aufgebaut.
    Beim Klick auf das interne DD-LW „Epson SMD-380“ geht
    die gelebe LED zwar an. Lesezugriff durch den Steppmotor
    erfolgt aber leider nicht 🙁 . . . LW ist gereinigt
    Nach dem lesen des Berichtes SMD-400 Wiederbelebung
    habe ich nun die Hoffnung, dass ich das SMD-380 mit
    etwas „Lötgeschick“ auch wieder ans Laufen bekomme.
    Folgende Kondi´s habe ich auf dem SMD-380 gefunden:

    1. direkt neben 5V Anschluss sitzt:
    1 dicker, brauer Kondensator; rel. gut aus-/einzulöten
    Bezeichnung: C01
    Farbe: braun
    Beschriftung oben 99 B3
    Beschriftung seite 56uF 16V
    Durchmesser: 6mm
    Höhe: 7,5mm

    2. hinter der Kunststoffblende (Disk-Einschub)
    sitzen 3 kleine schwarze Kondi´s (ähnlich SMD-400)
    alle 3 Kondi´s sind umgeklappt und an der Platine angeklebt
    Die Kondi-Beinchen können nicht durchgesteckt werden
    Die Löt-Anschlussstellen sind abgeflacht und 90° abgebogen

    Bezeichnung: C1 + C2 + C3 [(M) 88 CE 85°C]
    Farbe: schwarz
    Beschriftung oben — — (keine)
    Beschriftung seite 22uF 10V
    Durchmesser: 4mm
    Höhe: 6,5mm

    Feststellung:
    C2 + C3 sind gut zu erreichen
    C1 wird etwas fummelig, müsste aber auch gehen
    Die Pertinax-Platine im Bereich Einschub, ist unten aus Metall
    (geklebt !?)
    Alle 3 Kondi´s haben die gleiche Bezeichnung
    C1 – (M) 88 10 V 22uF CE 86°C
    C2 – (M) 88 10 V 22uF CE 86°C
    C3 – (M) 88 10 V 22uF CE 86°C

    Nun zu meinen Fragen:

    – sind außer den 4 Kondi´s noch weitere Kondi´s „versteckt“ ?
    – könnten ggf. noch weitere Bauteil/e defekt sein ?
    – wenn ja, welche ?
    – welche Tipps zum Reparaturversuch kannst Du mir noch geben ?

    P.S.
    Da die Kondi´s relativ günstig bei z.B. reichelt beschafft werden
    können, möchte ich den Reparaturversuch gerne durchführen.

    Vorab schon mal herzlichen Dank für Deine Unterstützung
    und viele Grüße

    Thomas

  2. Hallo Thomas, vielen Dank für Deine Frage. Leider kann ich Dir deine Fragen nicht beantworten. Das war einer der wenigen Artikel, die ich nicht selbst geschrieben habe. Mit dem Autor habe ich keinen Kontakt mehr und meine Kenntnisse in diesen Details sind mehr als gering. Außerdem habe ich diese Basteleien auf Grund meiner schlechten Augen aufgegeben. Tut mir leid.
    Viele Grüße
    Jungsi

  3. Hallo! Ganz dumme Frage: Ich will ein Check-up an meinem Laufwerk machen, aber trotzdem kann ich die Gehäuse(diese Metalschale) nicht entfernen. Ich weiß nicht wie man das macht. Würden Sie mir bitte ein bisschen erkären? Danke schön

    Stefan

  4. Hallo. Es gibt keine dummen Fragen. Leider kann ich hier nicht behilflich sein. Das ist der einzige Artikel im ganzen Blog, den ich bisher nicht selbst geschrieben hatte.
    Leider hab ich selbst keines dieser Laufwerke und mit dem Autor des Artikels habe ich leider keinen Kontakt mehr.
    Viele Grüße
    Gerhard

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert

Diese Website ist durch reCAPTCHA geschützt und es gelten die Datenschutzbestimmungen und Nutzungsbedingungen von Google

%d Bloggern gefällt das: